import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<xf:tokeninputrow.*\\/>";
final String string = "<xf:title>{{ phrase('start_conversation') }}</xf:title>\n\n"
+ "<xf:breadcrumb href=\"{{ link('conversations') }}\">{{ phrase('conversations') }}</xf:breadcrumb>\n\n"
+ "<xf:if contentcheck=\"true\">\n"
+ " <div class=\"blockMessage blockMessage--error blockMessage--iconic\">\n"
+ " <xf:contentcheck>\n"
+ " <xf:if is=\"$errorUsernames is not empty\">\n"
+ " <div>{{ phrase('you_can_not_start_conversation_with_following_users_because_of_privacy', {'usernames': $errorUsernames|join(', ')}) }}</div>\n"
+ " </xf:if>\n\n"
+ " <xf:if is=\"$notFoundUsernames is not empty\">\n"
+ " <div>{{ phrase('following_users_not_found_x', {'usernames': $notFoundUsernames|join(', ')}) }}</div>\n"
+ " </xf:if>\n\n"
+ " <xf:if is=\"$recipientLimit\">\n"
+ " <div>{{ phrase('you_have_exceeded_allowed_number_of_recipients_x_for', {'limit': $recipientLimit}) }}</div>\n"
+ " </xf:if>\n"
+ " </xf:contentcheck>\n"
+ " </div>\n"
+ "</xf:if>\n\n"
+ "<xf:form action=\"{{ link('conversations/add') }}\" ajax=\"true\" draft=\"{{ link('conversations/draft') }}\" data-preview-url=\"{{ link('conversations/add-preview') }}\" class=\"block\" data-xf-init=\"attachment-manager\">\n"
+ " <div class=\"block-container\">\n"
+ " <div class=\"block-body\">\n"
+ " <xf:tokeninputrow name=\"recipients\" value=\"{$to}\" href=\"{{ link('members/find') }}\"\n"
+ " rowtype=\"fullWidth\"\n"
+ " label=\"{{ phrase('recipients') }}\"\n"
+ " explain=\"{{ phrase('separate_names_with_comma') }}\" />\n\n"
+ " <xf:textboxrow name=\"title\" value=\"{$title}\" rowtype=\"fullWidth noLabel\" class=\"input--title\"\n"
+ " maxlength=\"{{ max_length('XF:ConversationMaster', 'title') }}\"\n"
+ " placeholder=\"{{ phrase('title...') }}\"\n"
+ " label=\"{{ phrase('title') }}\" />\n\n"
+ " <xf:editorrow name=\"message\"\n"
+ " value=\"{$message}\"\n"
+ " attachments=\"{{ $attachmentData ? $attachmentData.attachments : [] }}\"\n"
+ " rowtype=\"fullWidth noLabel mergePrev\" />\n\n"
+ " <xf:formrow>\n"
+ " <xf:if is=\"$attachmentData\">\n"
+ " <xf:macro template=\"helper_attach_upload\" name=\"upload_block\"\n"
+ " arg-attachmentData=\"{$attachmentData}\"\n"
+ " arg-forceHash=\"{$draft.attachment_hash}\" />\n"
+ " </xf:if>\n\n"
+ " <xf:if is=\"$xf.options.multiQuote\">\n"
+ " <xf:macro template=\"multi_quote_macros\" name=\"button\"\n"
+ " arg-href=\"{{ link('conversations/multi-quote', $conversation) }}\"\n"
+ " arg-messageSelector=\".js-message\"\n"
+ " arg-storageKey=\"multiQuoteConversation\" />\n"
+ " </xf:if>\n\n"
+ " <xf:button class=\"button--link u-jsOnly\" data-xf-click=\"preview-click\" icon=\"preview\" />\n"
+ " </xf:formrow>\n\n"
+ " <xf:checkboxrow>\n"
+ " <xf:option name=\"open_invite\" checked=\"{{ ($draft.open_invite OR $conversation.open_invite) ? 'checked' : '' }}\">\n"
+ " {{ phrase('allow_anyone_in_conversation_to_invite_others') }}\n"
+ " </xf:option>\n\n"
+ " <xf:option name=\"conversation_locked\" checked=\"{{ ($draft.conversation_open OR $conversation.conversation_open) ? '' : 'checked' }}\">\n"
+ " {{ phrase('lock_conversation_no_responses_will_be_allowed') }}\n"
+ " </xf:option>\n"
+ " </xf:checkboxrow>\n"
+ " </div>\n"
+ " <xf:submitrow submit=\"{{ phrase('start_conversation') }}\" sticky=\"true\" icon=\"conversation\">\n"
+ " <xf:html>\n"
+ " <xf:button class=\"u-jsOnly\" data-xf-click=\"preview-click\" icon=\"preview\" />\n"
+ " </xf:html>\n"
+ " </xf:submitrow>\n"
+ " </div>\n"
+ "</xf:form>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}