import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{2})\\s([\\d]{5})";
final String string = "Dave Martin\n"
+ "615-555-7164\n"
+ "173 Main St., Springfield RI 55924\n"
+ "davemartin@bogusemail.com\n\n"
+ "Charles Harris\n"
+ "800-555-5669\n"
+ "969 High St., Atlantis VA 34075\n"
+ "charlesharris@bogusemail.com\n\n"
+ "Eric Williams\n"
+ "560-555-5153\n"
+ "806 1st St., Faketown AK 86847\n"
+ "laurawilliams@bogusemail.com\n\n"
+ "Corey Jefferson\n"
+ "900-555-9340\n"
+ "826 Elm St., Epicburg NE 10671\n"
+ "coreyjefferson@bogusemail.com\n\n"
+ "Jennifer Martin-White\n"
+ "714-555-7405\n"
+ "212 Cedar St., Sunnydale CT 74983\n"
+ "jenniferwhite@bogusemail.com\n\n"
+ "Erick Davis\n"
+ "800-555-6771\n"
+ "519 Washington St., Olympus TN 32425\n"
+ "tomdavis@bogusemail.com\n\n"
+ "Neil Patterson\n"
+ "783-555-4799\n"
+ "625 Oak St., Dawnstar IL 61914\n"
+ "neilpatterson@bogusemail.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}