$re = '/^[a-z](?!.* {2})[ \w.-]{2,24}$/im';
$str = 'abc
a b
a12 34 56
a123 45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);