$re = '/(?<= (?# start lookbehind)
sample= (?# match sample= literally)
) (?# end lookbehind)
\S+ (?# match 1+ characters of non-whitespace)/x';
$str = 'random text sample=D30 more random text';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);