import Foundation
let pattern = ##"""
^((?!
PA(?:
\*(?:N\s*\d+\s*\.\s*\d+\s*\*ADP)?
| \#\s*N\s*\d+\s*
(?:\.\s*\d+\s*
(?:,\s*\d+\s*\.\s*\d+\s*)?
)?
\#ADP\s*\d
| \#\s*N\s*\d+\s*
(?:,\s*\d+\s*
(?:\.\s*\d+\s*,\s*\d+\s*)?
)?
\#ADP\s*\d
| \#\s*N(?:\s*\d+\s*,\s*)?
\s*\d+\s*
(?:\.\s*\d+\s*)?
(?:
[\.,]\s*\d+\s*,\s*\d+\s*
| -\s*\d+\s*
(?:\.\s*\d+\s*)?
)
\#ADP\s*\d
| \#\s*N\s*\d+\s*
\.\s*\d+\s*
-\s*\d+\s*
\.\s*\d+\s*
,\s*\d+\s*
\.\s*\d+\s*
\#ADP\s*\#PUSH
| \#NUAL,AZ,AN\#FOP\d
)
).)*$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ##"""
# OP's samples
PA#N1.1#ADP1
PA#N1.1,1.2#ADP1,2
PA#N1#ADP4
PA#N1,2#ADP4
PA#N1,2.1,3#ADP1
PA#N1.1-3#ADP1
PA#N1,1-3#ADP1
PA#N1.1- 3.2#ADP1,2
PA#NUAL,AZ,AN#FOP123
PA#N1.1-2.1,3.1#ADP#PUSH
PA*N1.1*ADP
PA*
# The same with some spaces adde here and there
PA# N 1.1 #ADP1
PA#N 1.1,1.2#ADP1,2
PA#N1#ADP4
PA#N1,2 #ADP4
PA#N1,2. 1,3#ADP1
PA#N1.1-3#ADP1
PA#N1.1- 3.2#ADP1,2
PA#NUAL,AZ,AN#FOP123
PA#N1.1-2 . 1 , 3 . 1 #ADP#PUSH
PA*N1 .1*ADP
PA#N1.1...#5#SOME TEXT
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)