$re = '/^[\d|\.|\,]+/';
$str = '123,13.45';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);