$re = '/\d/m';
$str = 'DIGIT ZERO 0
DIGIT ONE 1
DIGIT TWO 2
DIGIT THREE 3
DIGIT FOUR 4
DIGIT FIVE 5
DIGIT SIX 6
DIGIT SEVEN 7
DIGIT EIGHT 8
DIGIT NINE 9
ARABIC-INDIC DIGIT ZERO ٠
ARABIC-INDIC DIGIT ONE ١
ARABIC-INDIC DIGIT TWO ٢
ARABIC-INDIC DIGIT THREE ٣
ARABIC-INDIC DIGIT FOUR ٤
ARABIC-INDIC DIGIT FIVE ٥
ARABIC-INDIC DIGIT SIX ٦
ARABIC-INDIC DIGIT SEVEN ٧
ARABIC-INDIC DIGIT EIGHT ٨
ARABIC-INDIC DIGIT NINE ٩
EXTENDED ARABIC-INDIC DIGIT ZERO ۰
EXTENDED ARABIC-INDIC DIGIT ONE ۱
EXTENDED ARABIC-INDIC DIGIT TWO ۲
EXTENDED ARABIC-INDIC DIGIT THREE ۳
EXTENDED ARABIC-INDIC DIGIT FOUR ۴
EXTENDED ARABIC-INDIC DIGIT FIVE ۵
EXTENDED ARABIC-INDIC DIGIT SIX ۶
EXTENDED ARABIC-INDIC DIGIT SEVEN ۷
EXTENDED ARABIC-INDIC DIGIT EIGHT ۸
EXTENDED ARABIC-INDIC DIGIT NINE ۹
NKO DIGIT ZERO ߀
NKO DIGIT ONE ߁
NKO DIGIT TWO ߂
NKO DIGIT THREE ߃
NKO DIGIT FOUR ߄
NKO DIGIT FIVE ߅
NKO DIGIT SIX ߆
NKO DIGIT SEVEN ߇
NKO DIGIT EIGHT ߈
NKO DIGIT NINE ߉
DEVANAGARI DIGIT ZERO ०
DEVANAGARI DIGIT ONE १
DEVANAGARI DIGIT TWO २
DEVANAGARI DIGIT THREE ३
DEVANAGARI DIGIT FOUR ४
DEVANAGARI DIGIT FIVE ५
DEVANAGARI DIGIT SIX ६
DEVANAGARI DIGIT SEVEN ७
DEVANAGARI DIGIT EIGHT ८
DEVANAGARI DIGIT NINE ९
BENGALI DIGIT ZERO ০
BENGALI DIGIT ONE ১
BENGALI DIGIT TWO ২
BENGALI DIGIT THREE ৩
BENGALI DIGIT FOUR ৪
BENGALI DIGIT FIVE ৫
BENGALI DIGIT SIX ৬
BENGALI DIGIT SEVEN ৭
BENGALI DIGIT EIGHT ৮
BENGALI DIGIT NINE ৯
GURMUKHI DIGIT ZERO ੦
GURMUKHI DIGIT ONE ੧
GURMUKHI DIGIT TWO ੨
GURMUKHI DIGIT THREE ੩
GURMUKHI DIGIT FOUR ੪
GURMUKHI DIGIT FIVE ੫
GURMUKHI DIGIT SIX ੬
GURMUKHI DIGIT SEVEN ੭
GURMUKHI DIGIT EIGHT ੮
GURMUKHI DIGIT NINE ੯
GUJARATI DIGIT ZERO ૦
GUJARATI DIGIT ONE ૧
GUJARATI DIGIT TWO ૨
GUJARATI DIGIT THREE ૩
GUJARATI DIGIT FOUR ૪
GUJARATI DIGIT FIVE ૫
GUJARATI DIGIT SIX ૬
GUJARATI DIGIT SEVEN ૭
GUJARATI DIGIT EIGHT ૮
GUJARATI DIGIT NINE ૯
ORIYA DIGIT ZERO ୦
ORIYA DIGIT ONE ୧
ORIYA DIGIT TWO ୨
ORIYA DIGIT THREE ୩
ORIYA DIGIT FOUR ୪
ORIYA DIGIT FIVE ୫
ORIYA DIGIT SIX ୬
ORIYA DIGIT SEVEN ୭
ORIYA DIGIT EIGHT ୮
ORIYA DIGIT NINE ୯
TAMIL DIGIT ZERO ௦
TAMIL DIGIT ONE ௧
TAMIL DIGIT TWO ௨
TAMIL DIGIT THREE ௩
TAMIL DIGIT FOUR ௪
TAMIL DIGIT FIVE ௫
TAMIL DIGIT SIX ௬
TAMIL DIGIT SEVEN ௭
TAMIL DIGIT EIGHT ௮
TAMIL DIGIT NINE ௯
TELUGU DIGIT ZERO ౦
TELUGU DIGIT ONE ౧
TELUGU DIGIT TWO ౨
TELUGU DIGIT THREE ౩
TELUGU DIGIT FOUR ౪
TELUGU DIGIT FIVE ౫
TELUGU DIGIT SIX ౬
TELUGU DIGIT SEVEN ౭
TELUGU DIGIT EIGHT ౮
TELUGU DIGIT NINE ౯
KANNADA DIGIT ZERO ೦
KANNADA DIGIT ONE ೧
KANNADA DIGIT TWO ೨
KANNADA DIGIT THREE ೩
KANNADA DIGIT FOUR ೪
KANNADA DIGIT FIVE ೫
KANNADA DIGIT SIX ೬
KANNADA DIGIT SEVEN ೭
KANNADA DIGIT EIGHT ೮
KANNADA DIGIT NINE ೯
MALAYALAM DIGIT ZERO ൦
MALAYALAM DIGIT ONE ൧
MALAYALAM DIGIT TWO ൨
MALAYALAM DIGIT THREE ൩
MALAYALAM DIGIT FOUR ൪
MALAYALAM DIGIT FIVE ൫
MALAYALAM DIGIT SIX ൬
MALAYALAM DIGIT SEVEN ൭
MALAYALAM DIGIT EIGHT ൮
MALAYALAM DIGIT NINE ൯
SINHALA LITH DIGIT ZERO ෦
SINHALA LITH DIGIT ONE ෧
SINHALA LITH DIGIT TWO ෨
SINHALA LITH DIGIT THREE ෩
SINHALA LITH DIGIT FOUR ෪
SINHALA LITH DIGIT FIVE ෫
SINHALA LITH DIGIT SIX ෬
SINHALA LITH DIGIT SEVEN ෭
SINHALA LITH DIGIT EIGHT ෮
SINHALA LITH DIGIT NINE ෯
THAI DIGIT ZERO ๐
THAI DIGIT ONE ๑
THAI DIGIT TWO ๒
THAI DIGIT THREE ๓
THAI DIGIT FOUR ๔
THAI DIGIT FIVE ๕
THAI DIGIT SIX ๖
THAI DIGIT SEVEN ๗
THAI DIGIT EIGHT ๘
THAI DIGIT NINE ๙
LAO DIGIT ZERO ໐
LAO DIGIT ONE ໑
LAO DIGIT TWO ໒
LAO DIGIT THREE ໓
LAO DIGIT FOUR ໔
LAO DIGIT FIVE ໕
LAO DIGIT SIX ໖
LAO DIGIT SEVEN ໗
LAO DIGIT EIGHT ໘
LAO DIGIT NINE ໙
TIBETAN DIGIT ZERO ༠
TIBETAN DIGIT ONE ༡
TIBETAN DIGIT TWO ༢
TIBETAN DIGIT THREE ༣
TIBETAN DIGIT FOUR ༤
TIBETAN DIGIT FIVE ༥
TIBETAN DIGIT SIX ༦
TIBETAN DIGIT SEVEN ༧
TIBETAN DIGIT EIGHT ༨
TIBETAN DIGIT NINE ༩
MYANMAR DIGIT ZERO ၀
MYANMAR DIGIT ONE ၁
MYANMAR DIGIT TWO ၂
MYANMAR DIGIT THREE ၃
MYANMAR DIGIT FOUR ၄
MYANMAR DIGIT FIVE ၅
MYANMAR DIGIT SIX ၆
MYANMAR DIGIT SEVEN ၇
MYANMAR DIGIT EIGHT ၈
MYANMAR DIGIT NINE ၉
MYANMAR SHAN DIGIT ZERO ႐
MYANMAR SHAN DIGIT ONE ႑
MYANMAR SHAN DIGIT TWO ႒
MYANMAR SHAN DIGIT THREE ႓
MYANMAR SHAN DIGIT FOUR ႔
MYANMAR SHAN DIGIT FIVE ႕
MYANMAR SHAN DIGIT SIX ႖
MYANMAR SHAN DIGIT SEVEN ႗
MYANMAR SHAN DIGIT EIGHT ႘
MYANMAR SHAN DIGIT NINE ႙
KHMER DIGIT ZERO ០
KHMER DIGIT ONE ១
KHMER DIGIT TWO ២
KHMER DIGIT THREE ៣
KHMER DIGIT FOUR ៤
KHMER DIGIT FIVE ៥
KHMER DIGIT SIX ៦
KHMER DIGIT SEVEN ៧
KHMER DIGIT EIGHT ៨
KHMER DIGIT NINE ៩
MONGOLIAN DIGIT ZERO ᠐
MONGOLIAN DIGIT ONE ᠑
MONGOLIAN DIGIT TWO ᠒
MONGOLIAN DIGIT THREE ᠓
MONGOLIAN DIGIT FOUR ᠔
MONGOLIAN DIGIT FIVE ᠕
MONGOLIAN DIGIT SIX ᠖
MONGOLIAN DIGIT SEVEN ᠗
MONGOLIAN DIGIT EIGHT ᠘
MONGOLIAN DIGIT NINE ᠙
LIMBU DIGIT ZERO ᥆
LIMBU DIGIT ONE ᥇
LIMBU DIGIT TWO ᥈
LIMBU DIGIT THREE ᥉
LIMBU DIGIT FOUR ᥊
LIMBU DIGIT FIVE ᥋
LIMBU DIGIT SIX ᥌
LIMBU DIGIT SEVEN ᥍
LIMBU DIGIT EIGHT ᥎
LIMBU DIGIT NINE ᥏
NEW TAI LUE DIGIT ZERO ᧐
NEW TAI LUE DIGIT ONE ᧑
NEW TAI LUE DIGIT TWO ᧒
NEW TAI LUE DIGIT THREE ᧓
NEW TAI LUE DIGIT FOUR ᧔
NEW TAI LUE DIGIT FIVE ᧕
NEW TAI LUE DIGIT SIX ᧖
NEW TAI LUE DIGIT SEVEN ᧗
NEW TAI LUE DIGIT EIGHT ᧘
NEW TAI LUE DIGIT NINE ᧙
TAI THAM HORA DIGIT ZERO ᪀
TAI THAM HORA DIGIT ONE ᪁
TAI THAM HORA DIGIT TWO ᪂
TAI THAM HORA DIGIT THREE ᪃
TAI THAM HORA DIGIT FOUR ᪄
TAI THAM HORA DIGIT FIVE ᪅
TAI THAM HORA DIGIT SIX ᪆
TAI THAM HORA DIGIT SEVEN ᪇
TAI THAM HORA DIGIT EIGHT ᪈
TAI THAM HORA DIGIT NINE ᪉
TAI THAM THAM DIGIT ZERO ᪐
TAI THAM THAM DIGIT ONE ᪑
TAI THAM THAM DIGIT TWO ᪒
TAI THAM THAM DIGIT THREE ᪓
TAI THAM THAM DIGIT FOUR ᪔
TAI THAM THAM DIGIT FIVE ᪕
TAI THAM THAM DIGIT SIX ᪖
TAI THAM THAM DIGIT SEVEN ᪗
TAI THAM THAM DIGIT EIGHT ᪘
TAI THAM THAM DIGIT NINE ᪙
BALINESE DIGIT ZERO ᭐
BALINESE DIGIT ONE ᭑
BALINESE DIGIT TWO ᭒
BALINESE DIGIT THREE ᭓
BALINESE DIGIT FOUR ᭔
BALINESE DIGIT FIVE ᭕
BALINESE DIGIT SIX ᭖
BALINESE DIGIT SEVEN ᭗
BALINESE DIGIT EIGHT ᭘
BALINESE DIGIT NINE ᭙
SUNDANESE DIGIT ZERO ᮰
SUNDANESE DIGIT ONE ᮱
SUNDANESE DIGIT TWO ᮲
SUNDANESE DIGIT THREE ᮳
SUNDANESE DIGIT FOUR ᮴
SUNDANESE DIGIT FIVE ᮵
SUNDANESE DIGIT SIX ᮶
SUNDANESE DIGIT SEVEN ᮷
SUNDANESE DIGIT EIGHT ᮸
SUNDANESE DIGIT NINE ᮹
LEPCHA DIGIT ZERO ᱀
LEPCHA DIGIT ONE ᱁
LEPCHA DIGIT TWO ᱂
LEPCHA DIGIT THREE ᱃
LEPCHA DIGIT FOUR ᱄
LEPCHA DIGIT FIVE ᱅
LEPCHA DIGIT SIX ᱆
LEPCHA DIGIT SEVEN ᱇
LEPCHA DIGIT EIGHT ᱈
LEPCHA DIGIT NINE ᱉
OL CHIKI DIGIT ZERO ᱐
OL CHIKI DIGIT ONE ᱑
OL CHIKI DIGIT TWO ᱒
OL CHIKI DIGIT THREE ᱓
OL CHIKI DIGIT FOUR ᱔
OL CHIKI DIGIT FIVE ᱕
OL CHIKI DIGIT SIX ᱖
OL CHIKI DIGIT SEVEN ᱗
OL CHIKI DIGIT EIGHT ᱘
OL CHIKI DIGIT NINE ᱙
VAI DIGIT ZERO ꘠
VAI DIGIT ONE ꘡
VAI DIGIT TWO ꘢
VAI DIGIT THREE ꘣
VAI DIGIT FOUR ꘤
VAI DIGIT FIVE ꘥
VAI DIGIT SIX ꘦
VAI DIGIT SEVEN ꘧
VAI DIGIT EIGHT ꘨
VAI DIGIT NINE ꘩
SAURASHTRA DIGIT ZERO ꣐
SAURASHTRA DIGIT ONE ꣑
SAURASHTRA DIGIT TWO ꣒
SAURASHTRA DIGIT THREE ꣓
SAURASHTRA DIGIT FOUR ꣔
SAURASHTRA DIGIT FIVE ꣕
SAURASHTRA DIGIT SIX ꣖
SAURASHTRA DIGIT SEVEN ꣗
SAURASHTRA DIGIT EIGHT ꣘
SAURASHTRA DIGIT NINE ꣙
KAYAH LI DIGIT ZERO ꤀
KAYAH LI DIGIT ONE ꤁
KAYAH LI DIGIT TWO ꤂
KAYAH LI DIGIT THREE ꤃
KAYAH LI DIGIT FOUR ꤄
KAYAH LI DIGIT FIVE ꤅
KAYAH LI DIGIT SIX ꤆
KAYAH LI DIGIT SEVEN ꤇
KAYAH LI DIGIT EIGHT ꤈
KAYAH LI DIGIT NINE ꤉
JAVANESE DIGIT ZERO ꧐
JAVANESE DIGIT ONE ꧑
JAVANESE DIGIT TWO ꧒
JAVANESE DIGIT THREE ꧓
JAVANESE DIGIT FOUR ꧔
JAVANESE DIGIT FIVE ꧕
JAVANESE DIGIT SIX ꧖
JAVANESE DIGIT SEVEN ꧗
JAVANESE DIGIT EIGHT ꧘
JAVANESE DIGIT NINE ꧙
MYANMAR TAI LAING DIGIT ZERO ꧰
MYANMAR TAI LAING DIGIT ONE ꧱
MYANMAR TAI LAING DIGIT TWO ꧲
MYANMAR TAI LAING DIGIT THREE ꧳
MYANMAR TAI LAING DIGIT FOUR ꧴
MYANMAR TAI LAING DIGIT FIVE ꧵
MYANMAR TAI LAING DIGIT SIX ꧶
MYANMAR TAI LAING DIGIT SEVEN ꧷
MYANMAR TAI LAING DIGIT EIGHT ꧸
MYANMAR TAI LAING DIGIT NINE ꧹
CHAM DIGIT ZERO ꩐
CHAM DIGIT ONE ꩑
CHAM DIGIT TWO ꩒
CHAM DIGIT THREE ꩓
CHAM DIGIT FOUR ꩔
CHAM DIGIT FIVE ꩕
CHAM DIGIT SIX ꩖
CHAM DIGIT SEVEN ꩗
CHAM DIGIT EIGHT ꩘
CHAM DIGIT NINE ꩙
MEETEI MAYEK DIGIT ZERO ꯰
MEETEI MAYEK DIGIT ONE ꯱
MEETEI MAYEK DIGIT TWO ꯲
MEETEI MAYEK DIGIT THREE ꯳
MEETEI MAYEK DIGIT FOUR ꯴
MEETEI MAYEK DIGIT FIVE ꯵
MEETEI MAYEK DIGIT SIX ꯶
MEETEI MAYEK DIGIT SEVEN ꯷
MEETEI MAYEK DIGIT EIGHT ꯸
MEETEI MAYEK DIGIT NINE ꯹
FULLWIDTH DIGIT ZERO 0
FULLWIDTH DIGIT ONE 1
FULLWIDTH DIGIT TWO 2
FULLWIDTH DIGIT THREE 3
FULLWIDTH DIGIT FOUR 4
FULLWIDTH DIGIT FIVE 5
FULLWIDTH DIGIT SIX 6
FULLWIDTH DIGIT SEVEN 7
FULLWIDTH DIGIT EIGHT 8
FULLWIDTH DIGIT NINE 9
OSMANYA DIGIT ZERO 𐒠
OSMANYA DIGIT ONE 𐒡
OSMANYA DIGIT TWO 𐒢
OSMANYA DIGIT THREE 𐒣
OSMANYA DIGIT FOUR 𐒤
OSMANYA DIGIT FIVE 𐒥
OSMANYA DIGIT SIX 𐒦
OSMANYA DIGIT SEVEN 𐒧
OSMANYA DIGIT EIGHT 𐒨
OSMANYA DIGIT NINE 𐒩
HANIFI ROHINGYA DIGIT ZERO 𐴰
HANIFI ROHINGYA DIGIT ONE 𐴱
HANIFI ROHINGYA DIGIT TWO 𐴲
HANIFI ROHINGYA DIGIT THREE 𐴳
HANIFI ROHINGYA DIGIT FOUR 𐴴
HANIFI ROHINGYA DIGIT FIVE 𐴵
HANIFI ROHINGYA DIGIT SIX 𐴶
HANIFI ROHINGYA DIGIT SEVEN 𐴷
HANIFI ROHINGYA DIGIT EIGHT 𐴸
HANIFI ROHINGYA DIGIT NINE 𐴹
BRAHMI DIGIT ZERO 𑁦
BRAHMI DIGIT ONE 𑁧
BRAHMI DIGIT TWO 𑁨
BRAHMI DIGIT THREE 𑁩
BRAHMI DIGIT FOUR 𑁪
BRAHMI DIGIT FIVE 𑁫
BRAHMI DIGIT SIX 𑁬
BRAHMI DIGIT SEVEN 𑁭
BRAHMI DIGIT EIGHT 𑁮
BRAHMI DIGIT NINE 𑁯
SORA SOMPENG DIGIT ZERO 𑃰
SORA SOMPENG DIGIT ONE 𑃱
SORA SOMPENG DIGIT TWO 𑃲
SORA SOMPENG DIGIT THREE 𑃳
SORA SOMPENG DIGIT FOUR 𑃴
SORA SOMPENG DIGIT FIVE 𑃵
SORA SOMPENG DIGIT SIX 𑃶
SORA SOMPENG DIGIT SEVEN 𑃷
SORA SOMPENG DIGIT EIGHT 𑃸
SORA SOMPENG DIGIT NINE 𑃹
CHAKMA DIGIT ZERO 𑄶
CHAKMA DIGIT ONE 𑄷
CHAKMA DIGIT TWO 𑄸
CHAKMA DIGIT THREE 𑄹
CHAKMA DIGIT FOUR 𑄺
CHAKMA DIGIT FIVE 𑄻
CHAKMA DIGIT SIX 𑄼
CHAKMA DIGIT SEVEN 𑄽
CHAKMA DIGIT EIGHT 𑄾
CHAKMA DIGIT NINE 𑄿
SHARADA DIGIT ZERO 𑇐
SHARADA DIGIT ONE 𑇑
SHARADA DIGIT TWO 𑇒
SHARADA DIGIT THREE 𑇓
SHARADA DIGIT FOUR 𑇔
SHARADA DIGIT FIVE 𑇕
SHARADA DIGIT SIX 𑇖
SHARADA DIGIT SEVEN 𑇗
SHARADA DIGIT EIGHT 𑇘
SHARADA DIGIT NINE 𑇙
KHUDAWADI DIGIT ZERO 𑋰
KHUDAWADI DIGIT ONE 𑋱
KHUDAWADI DIGIT TWO 𑋲
KHUDAWADI DIGIT THREE 𑋳
KHUDAWADI DIGIT FOUR 𑋴
KHUDAWADI DIGIT FIVE 𑋵
KHUDAWADI DIGIT SIX 𑋶
KHUDAWADI DIGIT SEVEN 𑋷
KHUDAWADI DIGIT EIGHT 𑋸
KHUDAWADI DIGIT NINE 𑋹
NEWA DIGIT ZERO 𑑐
NEWA DIGIT ONE 𑑑
NEWA DIGIT TWO 𑑒
NEWA DIGIT THREE 𑑓
NEWA DIGIT FOUR 𑑔
NEWA DIGIT FIVE 𑑕
NEWA DIGIT SIX 𑑖
NEWA DIGIT SEVEN 𑑗
NEWA DIGIT EIGHT 𑑘
NEWA DIGIT NINE 𑑙
TIRHUTA DIGIT ZERO 𑓐
TIRHUTA DIGIT ONE 𑓑
TIRHUTA DIGIT TWO 𑓒
TIRHUTA DIGIT THREE 𑓓
TIRHUTA DIGIT FOUR 𑓔
TIRHUTA DIGIT FIVE 𑓕
TIRHUTA DIGIT SIX 𑓖
TIRHUTA DIGIT SEVEN 𑓗
TIRHUTA DIGIT EIGHT 𑓘
TIRHUTA DIGIT NINE 𑓙
MODI DIGIT ZERO 𑙐
MODI DIGIT ONE 𑙑
MODI DIGIT TWO 𑙒
MODI DIGIT THREE 𑙓
MODI DIGIT FOUR 𑙔
MODI DIGIT FIVE 𑙕
MODI DIGIT SIX 𑙖
MODI DIGIT SEVEN 𑙗
MODI DIGIT EIGHT 𑙘
MODI DIGIT NINE 𑙙
TAKRI DIGIT ZERO 𑛀
TAKRI DIGIT ONE 𑛁
TAKRI DIGIT TWO 𑛂
TAKRI DIGIT THREE 𑛃
TAKRI DIGIT FOUR 𑛄
TAKRI DIGIT FIVE 𑛅
TAKRI DIGIT SIX 𑛆
TAKRI DIGIT SEVEN 𑛇
TAKRI DIGIT EIGHT 𑛈
TAKRI DIGIT NINE 𑛉
AHOM DIGIT ZERO 𑜰
AHOM DIGIT ONE 𑜱
AHOM DIGIT TWO 𑜲
AHOM DIGIT THREE 𑜳
AHOM DIGIT FOUR 𑜴
AHOM DIGIT FIVE 𑜵
AHOM DIGIT SIX 𑜶
AHOM DIGIT SEVEN 𑜷
AHOM DIGIT EIGHT 𑜸
AHOM DIGIT NINE 𑜹
WARANG CITI DIGIT ZERO 𑣠
WARANG CITI DIGIT ONE 𑣡
WARANG CITI DIGIT TWO 𑣢
WARANG CITI DIGIT THREE 𑣣
WARANG CITI DIGIT FOUR 𑣤
WARANG CITI DIGIT FIVE 𑣥
WARANG CITI DIGIT SIX 𑣦
WARANG CITI DIGIT SEVEN 𑣧
WARANG CITI DIGIT EIGHT 𑣨
WARANG CITI DIGIT NINE 𑣩
DIVES AKURU DIGIT ZERO 𑥐
DIVES AKURU DIGIT ONE 𑥑
DIVES AKURU DIGIT TWO 𑥒
DIVES AKURU DIGIT THREE 𑥓
DIVES AKURU DIGIT FOUR 𑥔
DIVES AKURU DIGIT FIVE 𑥕
DIVES AKURU DIGIT SIX 𑥖
DIVES AKURU DIGIT SEVEN 𑥗
DIVES AKURU DIGIT EIGHT 𑥘
DIVES AKURU DIGIT NINE 𑥙
BHAIKSUKI DIGIT ZERO 𑱐
BHAIKSUKI DIGIT ONE 𑱑
BHAIKSUKI DIGIT TWO 𑱒
BHAIKSUKI DIGIT THREE 𑱓
BHAIKSUKI DIGIT FOUR 𑱔
BHAIKSUKI DIGIT FIVE 𑱕
BHAIKSUKI DIGIT SIX 𑱖
BHAIKSUKI DIGIT SEVEN 𑱗
BHAIKSUKI DIGIT EIGHT 𑱘
BHAIKSUKI DIGIT NINE 𑱙
MASARAM GONDI DIGIT ZERO 𑵐
MASARAM GONDI DIGIT ONE 𑵑
MASARAM GONDI DIGIT TWO 𑵒
MASARAM GONDI DIGIT THREE 𑵓
MASARAM GONDI DIGIT FOUR 𑵔
MASARAM GONDI DIGIT FIVE 𑵕
MASARAM GONDI DIGIT SIX 𑵖
MASARAM GONDI DIGIT SEVEN 𑵗
MASARAM GONDI DIGIT EIGHT 𑵘
MASARAM GONDI DIGIT NINE 𑵙
GUNJALA GONDI DIGIT ZERO 𑶠
GUNJALA GONDI DIGIT ONE 𑶡
GUNJALA GONDI DIGIT TWO 𑶢
GUNJALA GONDI DIGIT THREE 𑶣
GUNJALA GONDI DIGIT FOUR 𑶤
GUNJALA GONDI DIGIT FIVE 𑶥
GUNJALA GONDI DIGIT SIX 𑶦
GUNJALA GONDI DIGIT SEVEN 𑶧
GUNJALA GONDI DIGIT EIGHT 𑶨
GUNJALA GONDI DIGIT NINE 𑶩
KAWI DIGIT ZERO 𑽐
KAWI DIGIT ONE 𑽑
KAWI DIGIT TWO 𑽒
KAWI DIGIT THREE 𑽓
KAWI DIGIT FOUR 𑽔
KAWI DIGIT FIVE 𑽕
KAWI DIGIT SIX 𑽖
KAWI DIGIT SEVEN 𑽗
KAWI DIGIT EIGHT 𑽘
KAWI DIGIT NINE 𑽙
MRO DIGIT ZERO 𖩠
MRO DIGIT ONE 𖩡
MRO DIGIT TWO 𖩢
MRO DIGIT THREE 𖩣
MRO DIGIT FOUR 𖩤
MRO DIGIT FIVE 𖩥
MRO DIGIT SIX 𖩦
MRO DIGIT SEVEN 𖩧
MRO DIGIT EIGHT 𖩨
MRO DIGIT NINE 𖩩
TANGSA DIGIT ZERO 𖫀
TANGSA DIGIT ONE 𖫁
TANGSA DIGIT TWO 𖫂
TANGSA DIGIT THREE 𖫃
TANGSA DIGIT FOUR 𖫄
TANGSA DIGIT FIVE 𖫅
TANGSA DIGIT SIX 𖫆
TANGSA DIGIT SEVEN 𖫇
TANGSA DIGIT EIGHT 𖫈
TANGSA DIGIT NINE 𖫉
PAHAWH HMONG DIGIT ZERO 𖭐
PAHAWH HMONG DIGIT ONE 𖭑
PAHAWH HMONG DIGIT TWO 𖭒
PAHAWH HMONG DIGIT THREE 𖭓
PAHAWH HMONG DIGIT FOUR 𖭔
PAHAWH HMONG DIGIT FIVE 𖭕
PAHAWH HMONG DIGIT SIX 𖭖
PAHAWH HMONG DIGIT SEVEN 𖭗
PAHAWH HMONG DIGIT EIGHT 𖭘
PAHAWH HMONG DIGIT NINE 𖭙
MATHEMATICAL BOLD DIGIT ZERO 𝟎
MATHEMATICAL BOLD DIGIT ONE 𝟏
MATHEMATICAL BOLD DIGIT TWO 𝟐
MATHEMATICAL BOLD DIGIT THREE 𝟑
MATHEMATICAL BOLD DIGIT FOUR 𝟒
MATHEMATICAL BOLD DIGIT FIVE 𝟓
MATHEMATICAL BOLD DIGIT SIX 𝟔
MATHEMATICAL BOLD DIGIT SEVEN 𝟕
MATHEMATICAL BOLD DIGIT EIGHT 𝟖
MATHEMATICAL BOLD DIGIT NINE 𝟗
MATHEMATICAL DOUBLE-STRUCK DIGIT ZERO 𝟘
MATHEMATICAL DOUBLE-STRUCK DIGIT ONE 𝟙
MATHEMATICAL DOUBLE-STRUCK DIGIT TWO 𝟚
MATHEMATICAL DOUBLE-STRUCK DIGIT THREE 𝟛
MATHEMATICAL DOUBLE-STRUCK DIGIT FOUR 𝟜
MATHEMATICAL DOUBLE-STRUCK DIGIT FIVE 𝟝
MATHEMATICAL DOUBLE-STRUCK DIGIT SIX 𝟞
MATHEMATICAL DOUBLE-STRUCK DIGIT SEVEN 𝟟
MATHEMATICAL DOUBLE-STRUCK DIGIT EIGHT 𝟠
MATHEMATICAL DOUBLE-STRUCK DIGIT NINE 𝟡
MATHEMATICAL SANS-SERIF DIGIT ZERO 𝟢
MATHEMATICAL SANS-SERIF DIGIT ONE 𝟣
MATHEMATICAL SANS-SERIF DIGIT TWO 𝟤
MATHEMATICAL SANS-SERIF DIGIT THREE 𝟥
MATHEMATICAL SANS-SERIF DIGIT FOUR 𝟦
MATHEMATICAL SANS-SERIF DIGIT FIVE 𝟧
MATHEMATICAL SANS-SERIF DIGIT SIX 𝟨
MATHEMATICAL SANS-SERIF DIGIT SEVEN 𝟩
MATHEMATICAL SANS-SERIF DIGIT EIGHT 𝟪
MATHEMATICAL SANS-SERIF DIGIT NINE 𝟫
MATHEMATICAL SANS-SERIF BOLD DIGIT ZERO 𝟬
MATHEMATICAL SANS-SERIF BOLD DIGIT ONE 𝟭
MATHEMATICAL SANS-SERIF BOLD DIGIT TWO 𝟮
MATHEMATICAL SANS-SERIF BOLD DIGIT THREE 𝟯
MATHEMATICAL SANS-SERIF BOLD DIGIT FOUR 𝟰
MATHEMATICAL SANS-SERIF BOLD DIGIT FIVE 𝟱
MATHEMATICAL SANS-SERIF BOLD DIGIT SIX 𝟲
MATHEMATICAL SANS-SERIF BOLD DIGIT SEVEN 𝟳
MATHEMATICAL SANS-SERIF BOLD DIGIT EIGHT 𝟴
MATHEMATICAL SANS-SERIF BOLD DIGIT NINE 𝟵
MATHEMATICAL MONOSPACE DIGIT ZERO 𝟶
MATHEMATICAL MONOSPACE DIGIT ONE 𝟷
MATHEMATICAL MONOSPACE DIGIT TWO 𝟸
MATHEMATICAL MONOSPACE DIGIT THREE 𝟹
MATHEMATICAL MONOSPACE DIGIT FOUR 𝟺
MATHEMATICAL MONOSPACE DIGIT FIVE 𝟻
MATHEMATICAL MONOSPACE DIGIT SIX 𝟼
MATHEMATICAL MONOSPACE DIGIT SEVEN 𝟽
MATHEMATICAL MONOSPACE DIGIT EIGHT 𝟾
MATHEMATICAL MONOSPACE DIGIT NINE 𝟿
NYIAKENG PUACHUE HMONG DIGIT ZERO 𞅀
NYIAKENG PUACHUE HMONG DIGIT ONE 𞅁
NYIAKENG PUACHUE HMONG DIGIT TWO 𞅂
NYIAKENG PUACHUE HMONG DIGIT THREE 𞅃
NYIAKENG PUACHUE HMONG DIGIT FOUR 𞅄
NYIAKENG PUACHUE HMONG DIGIT FIVE 𞅅
NYIAKENG PUACHUE HMONG DIGIT SIX 𞅆
NYIAKENG PUACHUE HMONG DIGIT SEVEN 𞅇
NYIAKENG PUACHUE HMONG DIGIT EIGHT 𞅈
NYIAKENG PUACHUE HMONG DIGIT NINE 𞅉
WANCHO DIGIT ZERO 𞋰
WANCHO DIGIT ONE 𞋱
WANCHO DIGIT TWO 𞋲
WANCHO DIGIT THREE 𞋳
WANCHO DIGIT FOUR 𞋴
WANCHO DIGIT FIVE 𞋵
WANCHO DIGIT SIX 𞋶
WANCHO DIGIT SEVEN 𞋷
WANCHO DIGIT EIGHT 𞋸
WANCHO DIGIT NINE 𞋹
NAG MUNDARI DIGIT ZERO 𞓰
NAG MUNDARI DIGIT ONE 𞓱
NAG MUNDARI DIGIT TWO 𞓲
NAG MUNDARI DIGIT THREE 𞓳
NAG MUNDARI DIGIT FOUR 𞓴
NAG MUNDARI DIGIT FIVE 𞓵
NAG MUNDARI DIGIT SIX 𞓶
NAG MUNDARI DIGIT SEVEN 𞓷
NAG MUNDARI DIGIT EIGHT 𞓸
NAG MUNDARI DIGIT NINE 𞓹
ADLAM DIGIT ZERO 𞥐
ADLAM DIGIT ONE 𞥑
ADLAM DIGIT TWO 𞥒
ADLAM DIGIT THREE 𞥓
ADLAM DIGIT FOUR 𞥔
ADLAM DIGIT FIVE 𞥕
ADLAM DIGIT SIX 𞥖
ADLAM DIGIT SEVEN 𞥗
ADLAM DIGIT EIGHT 𞥘
ADLAM DIGIT NINE 𞥙
SEGMENTED DIGIT ZERO 🯰
SEGMENTED DIGIT ONE 🯱
SEGMENTED DIGIT TWO 🯲
SEGMENTED DIGIT THREE 🯳
SEGMENTED DIGIT FOUR 🯴
SEGMENTED DIGIT FIVE 🯵
SEGMENTED DIGIT SIX 🯶
SEGMENTED DIGIT SEVEN 🯷
SEGMENTED DIGIT EIGHT 🯸
SEGMENTED DIGIT NINE 🯹';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);