const regex = /\[[\w\s&.-]*\]'[\w\s&.-]+'![A-Z]{1,4}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[[\\w\\s&.-]*\\]\'[\\w\\s&.-]+\'![A-Z]{1,4}', 'gi')
const str = `[demo-_File.xls]'SheEt_nAme'!CA
[samPle file 2.xls]'demo Sheet'!D
###Inside the bracket and single quote:
-Accept any characters from a to z (Regardless of case)
-Accepts special characters -_. and space.
###After the exclamation mark, it should accept up to 4 capital characters.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}