re = /^\/product\/\d+\/[a-zA-Z0-9-]+$/im
str = '/product/9779/this-is-a-product
/product/27193/this-is-a-product-with-a-query-string?productId=50334&ps=True
/product/281727/this-is-another-product-with-a-really-long-title
/product/979
/product/979/product-12-pump-septic
/product/9790/the-1983-ford-sedan
/product/9791/remington-870-3-express-410-pump-shotgun
/category/2738/this-is-a-category'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end