$re = '/\s+/im';
$str = 'ABC
CBA
DDD
JKL';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;