#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Hometown: ([^<]+)(?=\s*<)"
Local $sString = "<strong><a href="/search/company/company/94613582">Anchor sample Ltd</a></strong><br>" & @CRLF & _
" BIS: 94613582 <br>" & @CRLF & _
" Hometown: MONTREAL <br>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class="hori"></div>" & @CRLF & _
"" & @CRLF & _
" <strong><a href="/search/company/company/046251945">Anchor sample Ltd</a></strong><br>" & @CRLF & _
" BIS: 046251945 <br>" & @CRLF & _
" Hometown: ALABAMA <br>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class="hori"></div>" & @CRLF & _
"" & @CRLF & _
" <strong><a href="/search/company/company/041634545">Anchor sample Ltd</a></strong><br>" & @CRLF & _
" BIS: 041634545 <br>" & @CRLF & _
" Hometown: GEORGIA <br>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class="hori"></div>" & @CRLF & _
"" & @CRLF & _
" <strong><a href="/search/company/company/487915646">Anchor sample Ltd</a></strong><br>" & @CRLF & _
" BIS: 487915646 <br>" & @CRLF & _
" Hometown: FLORIDA <br>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class="hori"></div>" & @CRLF & _
"" & @CRLF & _
" <strong><a href="/search/company/company/165875487">Anchor sample Ltd</a></strong><br>" & @CRLF & _
" BIS: 165875487 <br>" & @CRLF & _
" Hometown: KANSAS <br>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")