using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__\s*(['""])((?:(?!\1).)*)\1";
string input = @"__ 'Anything' and in __ ""Anything""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}