$re = '/\?>\s*\Z/';
$str = '<?php
function do_something() {
echo \'something\';
}
?> ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);