import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!x)(?<!\\border\\s*number\\W*)(?=(?:[._ –-]*\\d){9})(?!9|66\\D*6|00\\D*0|(?:\\d\\D*){3}0\\D*0|(?:\\d\\D*){5}0(?:\\D*0){3})\\d(?:[._ –-]*\\d){4}";
final String string = "x123456789\n"
+ "X123456789\n"
+ "x123-456-789\n"
+ "X123-456-789\n"
+ "123-456-789\n"
+ "ordernumber123-456-789\n"
+ "order number123-456789\n"
+ "order number 123456789\n"
+ "123-456789\n"
+ "123456789\n"
+ "ordernumber-x123456787\n"
+ "ordernumber-123456787\n"
+ "ordernumber - 123456789\n"
+ "ordernumber #123456789\n"
+ "ordernumber *anysplcharacter*123456789\n"
+ "ordernumber !@#$%^&123456789\n"
+ "123456789*@*#123456789\n"
+ "social security number 123-456-789\n"
+ "ordernumber !@#$%^&x123456789\n"
+ "123456789\n"
+ "#@%#$%#$123456789#$%#$^$#\n\n"
+ "123456789\n"
+ "123 45 6789\n"
+ "123-45-6789\n"
+ "123-45-6789\n"
+ "123 – 45 – 6789\n"
+ "123.45.6789\n"
+ "123_45_6789\n"
+ "123 456 789\n"
+ "123-456-789\n"
+ "123 – 456 – 789\n"
+ "123.456.789\n"
+ "123_456_789\n"
+ "1234 56 789\n"
+ "1234-56-789\n"
+ "1234 – 56 – 789\n"
+ "1234.56.789\n"
+ "1234_56_789\n"
+ "12 345 6789\n"
+ "12-345-6789\n"
+ "12 – 345 – 6789\n"
+ "12.345.6789\n"
+ "12_345_6789\n\n"
+ "The number should not be matched at all for the following rules.\n\n"
+ "If the number beginning with the number “9”\n"
+ "912345678\n"
+ "912000000\n\n"
+ "If the number “666” in positions 1 – 3.\n"
+ "666000000\n"
+ "666450000\n"
+ "666129876\n\n"
+ "If the number “000” in positions 1 – 3.\n"
+ "000000000\n"
+ "000450000\n"
+ "000120000\n\n"
+ "If the number “00” in positions 4 – 5.\n"
+ "123006789\n"
+ "876001234\n"
+ "765003456\n\n"
+ "if the number “0000” in positions 6 – 9\n"
+ "123450000\n"
+ "123000000\n"
+ "876000000\n\n"
+ "x123456789\n"
+ "X123456789\n"
+ "x123-456-789\n"
+ "X123-456-789\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}