using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"amazonaws.com\/([^\?]+)";
string input = @"http://some-website.s3.amazonaws.com/lovecraft-05.epub?AWSAccessKeyId=KJHFHGFDSXF&Expires=3568732&Signature=%3JHF%3KUHF%2Bnuvnu%5LHF%3D";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}