package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)for( )+(([$,_,?,!,*]*[A-Z]*+[a-z]*)+)[ ]+in( )+([\D]+([(][\D]*[)])?):`)
var str = `for *Col in lol:
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}