$re = '/\[(?:[^][]++|(?R))*]/m';
$str = '[tex1] [text [2]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);