re = /(?=[01467]{10})(?=(?:[^0]*0){2})(?=(?:[^1]*1){2})(?=[^4]*4)(?=(?:[^6]*6){3})(?=(?:[^7]*7){2}).{10}/m
str = '0046711766'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end