$re = '/(\d+\.\d{4})/';
$str = '110.0046102.005699.0008103.0104';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);