$re = '/^(?:music|pictures)\/tom((?:\/(?:[\w-]+(?:[ ]+[\w-]+)*))+)$/m';
$str = 'music/tom/foldername
music/tom/folder name
music/tom/foldername/folder2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);