$re = '/(?<=\"alt\=\")[^"]+/m';
$str = 'afsd fasd fasdf asdf "alt="какой-то текст"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);