import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[!]\\[(?P<caption>.*?)\\])\\((?P<image>.*?)\\)";
final String string = "This is a regex to detect markdown image links of the form \n\n"
+ "Here are some markdown links\n"
+ "- [pandoc-fignos](https://github.com/tomduck/pandoc-fignos): Numbers figures and figure references.\n"
+ "The images section will walk you through how to add and reference images so that the pandoc system can properly number them. For example, this [figure](./ch0_1_images.md#fig:ch0_1_images-1) illustrates a VOD curve for a packaged watergel explosive and this [figure](./ch0_1_images.md#fig:ch0_1_images-2) depicts a circular arc.\n"
+ "## [Equations](./ch0_2_equations.md#sec:ch0_2_equations-1)\n"
+ "The equations section will discuss how to use equations and reference them properly. See the [internal energy equation](./ch0_2_equations.md#eq:ch0_2_equations-1) or the [detonation pressure](./ch0_2_equations.md#eq:ch0_2_equations-2)\n"
+ "This string does not contain any links\n\n"
+ "Here are some image links:\n"
+ "{#fig:id}\n"
+ "{#fig:id tag=\"B.1\"}\n"
+ "{#fig:ch0_1_images-1 width=100%}\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "\n"
+ "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}