re = /(\d.{0,}\.\d{0,})/
str = '========================================
1.123
1,000.0132
1,000,000.123
1 000.123
1 000 000.123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end