re = /{(?<tag>[^:=]*)(?::(?<value>[^=]*))?=(?<text>[^}]*)}/
str = '{tag:value=text}
{tag=text}
{tag:=text}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end