$re = '/\d(?:[()\s#-]*\d){3,}/';
$str = '123 41
>
1 2 --2 -4
>
1 234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);