re = /^(.*?) ?([^ (]+) *\((.*)\);/m
str = 'void(*ClutterBehaviourForeachFunc) (ClutterBehaviour *behaviour, ClutterActor *actor, gpointer data);
void (*ClutterBehaviourForeachFunc) (ClutterBehaviour *behaviour, ClutterActor *actor, gpointer data);
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end