re = /content="(?<Name>.*?)"/
str = '<meta content="Gizmo" property="og:title" />
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end