$re = '/^(?:\d{1,3}(?:,\d{3})*|\d+)(?:\.\d+)?$/m';
$str = '11111111111.55
1,111.78';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);