package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,3}(?:,\d{3})*(?:\.\d+)?$`)
var str = `11111111111.55
1,111.78`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}