$re = '/^[a-z][0-9]{3}[a-z]{2}$/i';
$str = 'z123zz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);