$re = '/(\\\\)(?=\")/m';
$str = '"Hello\\na = a.split(\\"\\n\\")';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;