$re = '/^(?![^ .-]*[ .-]{2})((\+|00)[1-9]{1,3})?[ .-]?((\d{0,3})[ .-]?(\d{5,11}))$/m';
$str = '+39123456789
+39-123-456789
+39 123 456789
+39 123456789
+39-123 456789
+39.123.456789
+39 123.456789
+39-123.456789
+39- 123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);