import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<textarea\\b[^>]*>((\\n*|.)*)<\\/textarea>";
final String string = "<p>\n"
+ " <textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">\n"
+ " <p>5051950</p>\n"
+ " </textarea>\n"
+ "</p>\n\n"
+ "<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">teste teste teste teste teste</textarea></p>\n\n"
+ "<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\"></textarea></p>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}