$re = '/^[\w-]+(?: +[\w-]+)*$/m';
$str = '
abc 123
ab_ 24_
a b c 1 2 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);