const regex = /\v(knop\.\h*(\v|$))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\v(knop\\.\\h*(\\v|$))', '')
const str = `PROGNOS FÖR OMRÅDE B DEN SÖDRA DELEN
GÄLLANDE DEN 31 JANUARI 2016 MELLAN 08 OCH 14 UTC
Turbulens
Område 3a,3b,3c,3d: Mot slutet av perioden måttlig turbulens,
SFC-3000ft.
Isbildning
Område 1b,1c,3a: I mitten och mot slutet av perioden lätt till
måttlig isbildning mellan 1000ft och FL070.
Område 2a,2b,3b,3c,3d: Under hela perioden lätt till måttlig
isbildning mellan 1000ft och FL070.
Sikt/Väder/Moln
Område 3c: I början av perioden sikt över 8km snöfall, lokalt
1500-3000m i snöblandat regn. Molnbas över 2000ft, lokalt 500-1000ft.
Molnöversida FL070. I mitten av perioden sikt över 8km, lokalt
3000-5000m i snöfall. Molnbas 500-1000ft, lokalt över 2000ft.
Molnöversida FL070. Mot slutet av perioden sikt över 8km. Molnbas
över 2000ft. Molnöversida FL070.
Område 2b: I början och mitten av perioden sikt över 8km, lokalt
1500-3000m i snöfall. Molnbas över 2000ft, lokalt under 500ft.
Molnöversida FL070. Mot slutet av perioden sikt över 8km, lokalt
3000-5000m i snöfall. Molnbas över 2000ft, lokalt 500-1000ft.
Molnöversida >FL125.
Område 3b: I början och mitten av perioden sikt 1500-3000m snöfall,
lokalt över 8km. Molnbas över 2000ft, lokalt under 500ft.
Molnöversida FL070. Mot slutet av perioden sikt över 8km. Molnbas
över 2000ft. Molnöversida FL070.
Område 2c: Under hela perioden sikt över 8km. Molnbas över 2000ft.
Molnöversida FL070.
Område 3d: I början av perioden sikt över 8km snöfall, lokalt
1500-3000m i snöblandat regn. Molnbas 500-1000ft, lokalt över 2000ft.
Molnöversida FL070. I mitten av perioden sikt över 8km, lokalt
3000-5000m i snöfall. Molnbas 500-1000ft, lokalt över 2000ft.
Molnöversida FL070. Mot slutet av perioden sikt över 8km. Molnbas
över 2000ft. Molnöversida FL070.
Område 1a: Under hela perioden sikt över 8km. Molnbas över 2000ft.
Molnöversida: Ingen prognos.
Område 1c: Under hela perioden sikt över 8km. Molnbas över 2000ft,
lokalt 500-1000ft. Molnöversida FL070.
Område 2a: Under hela perioden sikt 1500-3000m snöfall, lokalt över
8km. Molnbas över 2000ft, lokalt under 500ft. Molnöversida >FL125.
Område 1b: I början av perioden sikt över 8km. Molnbas över 2000ft.
Molnöversida: Ingen prognos. I mitten och mot slutet av perioden sikt
över 8km. Molnbas över 2000ft, lokalt 500-1000ft. Molnöversida FL070.
Område 3a: I början av perioden sikt över 8km. Molnbas över 2000ft.
Molnöversida: Ingen prognos. I mitten av perioden sikt över 8km,
lokalt 1500-3000m i snöfall. Molnbas över 2000ft, lokalt under 500ft.
Molnöversida FL070. Mot slutet av perioden sikt över 8km, lokalt
3000-5000m i snöfall. Molnbas över 2000ft, lokalt 500-1000ft.
Molnöversida FL070.
Nollgradersisoterm
I hela området: Noll grader vid 500ft.
Vind vid marken
Område 2b,2c: S-SV/5-10 knop, efterhand S-SV/10 knop.
Område 3b,3c,3d: SV-V/10-15 knop, byar upp till 25 knop, efterhand
V/15-20 knop, byar upp till 30 knop.
Område 3a: S-SV/5-10 knop, efterhand V/15-20 knop, byar upp till 30
knop.
Område 1a: SV/10-15 knop.
Område 2a: SV-V/10-15 knop, byar upp till 25 knop.
Område 1b,1c: SV/15-20 knop, efterhand SV-V/15-20 knop.
Vind och temperatur
2000ft:
I hela området: 240/25kt -1, efterhand 260/25kt -1
FL50:
I hela området: 260/25kt -7, efterhand 280/30kt -8
FL100:
I hela området: 250/25kt -17, efterhand 270/30kt -17
Lägsta QNH
982 hPa, lägst i norr, stigande
Tilläggsinformation
Förekomsten av TCU eller CB innebär alltid risk för måttlig till svår
isbildning och turbulens, även om det inte framgår explicit av
prognosen.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);