#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http[s]?:\/\/www\.linkedin\.com\/(?:in|pub|public-profile\/in|public-profile\/pub)\/(?:[\w]{6}-[\w]{1,}-[\w]+)$"
Local $sString = "https://www.linkedin.com/in/XXXXXX-XXXXX-55301b41" & @CRLF & _
"https://www.linkedin.com/pub/XXXXXX-XXXXX-55301b41" & @CRLF & _
"https://www.linkedin.com/public-profile/in/XXXXXX-XXXX-b82a7b10a" & @CRLF & _
"https://www.linkedin.com/public-profile/pub/XXXXXX-XXXX-b82a7b10a" & @CRLF & _
"" & @CRLF & _
"https://www.linkedin.com/in/xxxx-xxxx-ab85a328/%7Bcountry%3Dde%2C+language%3Dde%7D?trk=people-guest_profile-result-card_result-card_full-click" & @CRLF & _
"https://www.linkedin.com/edu/school?id=18987" & @CRLF & _
"https://www.linkedin.com/in/xxxx-xxxx-55301b41/de" & @CRLF & _
"https://www.linkedin.com/pub/xxxxx-xxxxx/98/b7a/22b" & @CRLF & _
"https://it.linkedin.com/public-profile/in/xxxx-xxxxx-80520667?challengeId=AQEV3tHveORYsAAAAXQqx1N3bZ7fd44s5ngegJp6rC0UoWvhG2LtAhhgld8h3QyBxorfcLL2iuvK4xh_UKoGguxvX6sFx_nnZA&submissionId=7bc972ed-bfd1-2e16-c395-ad35cb550117" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")