package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{1,3}\.?(?:\d{1,3}\.?)* )?[^\W\d]+`)
var str = `section
1 section
2. section
2.1 subsection
2.1.1 subsection
2.1.1. subsection
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}