package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`UNIT OPENER`)
var str = `NGSS Lesson Outline with Manuscript
HISTORY
Version Stage Writer/Reviewer Notes Date
1 Dev Prep1 Maryum Mohsin Script build prep 9-9-16
Contents
HISTORY 1
UNIT OVERVIEW 1
UNIT OPENER 1
UNIT PROJECT 1
VOCABULARY 2
UNIT OVERVIEW
CODE TK
Grade Level 2
Unit Title Earth’s Surface
UNIT OPENER
Page Title Unit Opener
Section Part Content
UnitOpener_1 Habitat Pattern: STATIC – Unit Opener SCREEN VO: Unit 4 Earth’s Su
rface [RCE Head]: Unit 4 Earth’s Surface Media: Splash: Spec ID# 883V Text [I
mage Caption]:
UNIT PROJECT
Page Title Unit 4 Project
Section Part Content
UnitProject_1 Habitat Pattern: STATIC – Intro Unit Project SCREEN VO: Why does
n’t an ocean freeze completely? Investigate to find out. [RCE Head]: Unit 4 Pro
ject Text [Head]: Explore Ocean Water Text [Directional Text]: Why does an oce
an not freeze completely? Investigate to find out. Media: Spec ID# 884P Text [I
mage Caption]: [icon w/ link to downloadable worksheet]
VOCABULARY
Page Title Unit Review
Section Part Content
UnitVocabulary_1 Habitat Pattern: INTERACTIVE – TR_Main [RCE head]: Unit 4 Voca
bulary SCREEN VO: Unit 4 Vocabulary Each card shows a word you will use in thi
s unit. Choose a card to find out more about the word. Text [Directional Text]:
Each card shows a word you will use in this unit. Choose a card to find out mo
re about the word. Media and Options: Voc1: mapVoc2: map titleVoc3: map keyVoc4
: compass rose
Voc1: Text [label]: map Image1: Spec ID# 900M [simple town map p/u 463M]] Text
VO: map a drawing or a model of a place Voc2: Text [label]: map title Image2: S
pec ID# 901M [close up of map title p/u 464M] Text VO: map title part of a map t
hat tells what the map shows Voc3: Text [label]: map key Image3: Spec ID# 902M
[close up of map key p/u 464M] Text VO: map key part of a map that shows what t
he map colors and symbols mean Voc4: Text [label]: compass rose Image4: Spec ID
# 903M [close up of compass rose p/u 464M] Text VO: compass rose part of a map t
hat shows the directions north, south, east, and west
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}