import re
regex = re.compile(r"^\+?(0*[1-9]\d*(?:[\., ]\d+)*) *(?:\p{Sc}|°[FC])?$", flags=re.MULTILINE)
test_str = ("All real numbers can be divided into three categories: positive, negative and zero;\n"
"Match all positive number\n\n"
"Match:\n"
"2\n"
"9 \n"
"+8\n"
"005\n"
"0420\n"
"123456789\n"
"40.262,12\n"
"+042 262,12\n"
"421.265.195,52\n"
"0420 $\n"
"0420 €\n"
"35 °C\n"
"12 °F\n\n"
"No Match:\n"
"0\n"
"00000 0000\n"
"-10\n"
"-1\n"
"10a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")