using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(,([^\s]))|([:])";
string input = @"Hey,This comma will be captured.
hey, this won't be captured.
Hey:this colon will be captured.
Hey: this colon will be captured too.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}