#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]\d{0,2}(,\d{3}){0,3})$|^([1-9]\d?(,\d{3}){4})$"
Local $sString = "1" & @CRLF & _
"10" & @CRLF & _
"100" & @CRLF & _
"1,000" & @CRLF & _
"10,000" & @CRLF & _
"100,000" & @CRLF & _
"1,000,000" & @CRLF & _
"10,000,000" & @CRLF & _
"100,000,000" & @CRLF & _
"1,000,000,000" & @CRLF & _
"10,000,000,000" & @CRLF & _
"100,000,000,000" & @CRLF & _
"1,000,000,000,000" & @CRLF & _
"10,000,000,000,000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")