import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(\\w+)\\s)?.*?([\\w\\d\\-]+)\\s*(?:CPU)?\\s*@\\s*(\\d+\\.\\d+GHz)$";
final String string = "Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz\n"
+ "Genuine Intel(R) CPU T2400 @ 1.83GHz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}