import re
regex = re.compile(r"Samsung(?=.*?Galaxy S)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("$data =\n"
"Array\n"
"(\n"
" [0] => Array\n"
" (\n"
" [name] => Samsung GT-N7100 Galaxy Note II 16GB\n"
" )\n\n"
" [1] => Array\n"
" (\n"
" [name] => Samsung GT-i9100 Galaxy S II\n"
" )\n\n"
" [2] => Array\n"
" (\n"
" [name] => Samsung GT-i9300 Galaxy S III 16GB\n"
" )\n\n"
" [3] => Array\n"
" (\n"
" [name] => Apple iPhone 5 16GB\n"
" )\n\n"
" [4] => Array\n"
" (\n"
" [name] => Samsung GT-P5110 Galaxy S 4 10.1 16GB\n"
" )\n\n"
" [5] => Array\n"
" (\n"
" [name] => Samsung UE46ES6715\n"
" )\n\n"
" [6] => Array\n"
" (\n"
" [name] => Samsung 830 Series MZ-7PC128 128GB\n"
" )\n\n"
" [7] => Array\n"
" (\n"
" [name] => Samsung GT-N8000 Galaxy Note 10.1 16GB\n"
" )\n\n"
" [8] => Array\n"
" (\n"
" [name] => Samsung 830 Series MZ-7PC256 256GB\n"
" )\n\n"
" [9] => Array\n"
" (\n"
" [name] => Samsung UE46ES6715\n"
" )\n\n"
" [10] => Array\n"
" (\n"
" [name] => Samsung GT-2423 Galaxy Tab 4 10.1 16GB\n"
" )")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")