re = /(?<=;|^)[0-9]+(?:-[0-9]+|(?=;|$))/m
str = '123
123-234;FOO-456;45-67;FOO-FOO;890;FOO-123;11-22;123;123;44-55;098-567;890;123-FOO;
123-456
123-FOO
FOO-123
FOO-FOO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end