$re = '/a.{10}/';
$str = 'hello world a is a very nice letter';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);