const regex = /^\d{0,6}(\.\d{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{0,6}(\\.\\d{1,2})?$', 'gm')
const str = `123456.12
21231
123456
15465.43
23.34
6.45
12345678
123456.331`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);