#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(aS)\s+((\`)?\w+(\`)?)(\s+|\,|(FRom\s+))"
Local $sString = " SELECT " & @CRLF & _
" a.WORKORDER_NO AS workOrderNo, " & @CRLF & _
" a.ORD_TYPE AS ordType, " & @CRLF & _
" a.ORD_NO AS ordNo, " & @CRLF & _
" a.RETURN_FLAG AS returnFlag, " & @CRLF & _
" a.AREA_ID AS areaId, " & @CRLF & _
" a.USER_NAME AS userName, " & @CRLF & _
" a.ADDR_DETAIL AS addrDetail, " & @CRLF & _
" a.HANDLE_STAFF_ID AS handleStaffId, " & @CRLF & _
" a.TAKE_STAFF_ID AS takeStaffId, " & @CRLF & _
" a.TAKE_TS AS takeTs, " & @CRLF & _
" a.RETURN_STAFF_ID AS returnStaffId, " & @CRLF & _
" a.RETURN_TS AS returnTs, " & @CRLF & _
" a.SUMMARY AS summary, " & @CRLF & _
" a.WO_TITLE AS woTitle, " & @CRLF & _
" a.INSTALL_FLAG AS installFlag, " & @CRLF & _
" a.START_TS AS startTs, " & @CRLF & _
" a.END_TS AS endTs, " & @CRLF & _
" a.GRID_ID AS gridId, " & @CRLF & _
" a.SCHEMA_ID AS schemaId, " & @CRLF & _
" a.PROJECT_ID AS projectId, " & @CRLF & _
" a.COMMENTS AS comments, " & @CRLF & _
" a.STATE AS `state`, " & @CRLF & _
" a.CREATE_USER AS createUser, " & @CRLF & _
" a.CREATE_DATE AS createDate, " & @CRLF & _
" a.MODIFY_USER AS modifyUser, " & @CRLF & _
" a.MODIFY_DATE AS modifyDate, " & @CRLF & _
" a.HANDLE_TEAM_ID AS handleTeamId, " & @CRLF & _
" a.PACKAGE_ID AS packageId, " & @CRLF & _
" a.PACKAGE_NAME AS packageName, " & @CRLF & _
" a.SUB_TYPE AS subType, " & @CRLF & _
" a.pre_work_order_no AS preWorkOrderNo, " & @CRLF & _
" a.IS_SYNC AS isSync, " & @CRLF & _
" a.IS_VIRTUAL AS isVirtual, " & @CRLF & _
" a.VIRTUAL_WORKORDER_NO AS virtualWorkOrderNo, " & @CRLF & _
" a.VIRTUAL_WORKORDER_RES_ID AS virtualWorkOrderResId, " & @CRLF & _
" a.IS_POLE AS isPole, " & @CRLF & _
" a.VER_NO AS verNo, " & @CRLF & _
" a.TASK_ID AS taskId, " & @CRLF & _
" " & @CRLF & _
" b.USER_NAME AS userName " & @CRLF & _
" " & @CRLF & _
" FROM oss_edn.edn_work_order a " & @CRLF & _
" LEFT JOIN oss_wfm.wfs_user_infor b ON a.HANDLE_STAFF_ID = b.USER_ID " & @CRLF & _
" WHERE a.WORKORDER_NO = :workOrderNo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")