#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(DELIMITER ;;[\S\s]*?DELIMITER ;)"
Local $sString = "--" & @CRLF & _
"-- Dumping data for table `SOME_TABLE`" & @CRLF & _
"--" & @CRLF & _
"" & @CRLF & _
"LOCK TABLES `SOME_TABLE` WRITE;" & @CRLF & _
"/*!40000 ALTER TABLE `SOME_TABLE` DISABLE KEYS */;" & @CRLF & _
"/*!40000 ALTER TABLE `SOME_TABLE` ENABLE KEYS */;" & @CRLF & _
"UNLOCK TABLES;" & @CRLF & _
"/*!50003 SET @saved_cs_client = @@character_set_client */ ;" & @CRLF & _
"/*!50003 SET @saved_cs_results = @@character_set_results */ ;" & @CRLF & _
"/*!50003 SET @saved_col_connection = @@collation_connection */ ;" & @CRLF & _
"/*!50003 SET character_set_client = utf8 */ ;" & @CRLF & _
"/*!50003 SET character_set_results = utf8 */ ;" & @CRLF & _
"/*!50003 SET collation_connection = utf8_general_ci */ ;" & @CRLF & _
"/*!50003 SET @saved_sql_mode = @@sql_mode */ ;" & @CRLF & _
"/*!50003 SET sql_mode = 'ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION' */ ;" & @CRLF & _
"DELIMITER ;;" & @CRLF & _
"/*!50003 CREATE*/ /*!50017 */ /*!50003 TRIGGER SOME_TABLE_BU BEFORE UPDATE ON SOME_TABLE " & @CRLF & _
"FOR EACH ROW" & @CRLF & _
"" & @CRLF & _
"BEGIN " & @CRLF & _
" " & @CRLF & _
" IF (OLD.DUE_DATE<>NEW.DUE_DATE) THEN" & @CRLF & _
" SET NEW.COUNT=0;" & @CRLF & _
" INSERT INTO SOME_TABLE_RESET_COUNT(SOME_TABLE_ID,CAL_DUE_DATE,COUNT,USER_ID) VALUES(OLD.ID,OLD.DUE_DATE,OLD.CYCLE_COUNT,NEW.CAL_BY);" & @CRLF & _
" END IF;" & @CRLF & _
"END */;;" & @CRLF & _
"DELIMITER ;" & @CRLF & _
"/*!50003 SET sql_mode = @saved_sql_mode */ ;" & @CRLF & _
"/*!50003 SET character_set_client = @saved_cs_client */ ;" & @CRLF & _
"/*!50003 SET character_set_results = @saved_cs_results */ ;" & @CRLF & _
"/*!50003 SET collation_connection = @saved_col_connection */ ;" & @CRLF & _
"/*!50003 SET @saved_cs_client = @@character_set_client */ ;" & @CRLF & _
"/*!50003 SET @saved_cs_results = @@character_set_results */ ;" & @CRLF & _
"/*!50003 SET @saved_col_connection = @@collation_connection */ ;" & @CRLF & _
"/*!50003 SET character_set_client = utf8 */ ;" & @CRLF & _
"/*!50003 SET character_set_results = utf8 */ ;" & @CRLF & _
"/*!50003 SET collation_connection = utf8_general_ci */ ;" & @CRLF & _
"/*!50003 SET @saved_sql_mode = @@sql_mode */ ;" & @CRLF & _
"/*!50003 SET sql_mode = 'NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION' */ ;" & @CRLF & _
"DELIMITER ;;" & @CRLF & _
"/*!50003 CREATE*/ /*!50017 */ /*!50003 TRIGGER SOME_TABLE_AU" & @CRLF & _
"AFTER UPDATE ON SOME_TABLE " & @CRLF & _
"FOR EACH ROW" & @CRLF & _
"" & @CRLF & _
"BEGIN " & @CRLF & _
" IF IFNULL(OLD.RESET_REASON,'') <> IFNULL(NEW.RESET_REASON,'') THEN" & @CRLF & _
" INSERT INTO SOME_TABLE_RESET_NEXT_DUE(REASON,SOME_TABLE_ID,NEW_CAL_DATE,OLD_CAL_DATE)" & @CRLF & _
" VALUES(NEW.RESET_REASON,NEW.ID,NEW.DUE_DATE,OLD.DUE_DATE);" & @CRLF & _
" END IF;" & @CRLF & _
"END */;;" & @CRLF & _
"DELIMITER ;" & @CRLF & _
"/*!50003 SET sql_mode = @saved_sql_mode */ ;" & @CRLF & _
"/*!50003 SET character_set_client = @saved_cs_client */ ;" & @CRLF & _
"/*!50003 SET character_set_results = @saved_cs_results */ ;" & @CRLF & _
"/*!50003 SET collation_connection = @saved_col_connection */ ;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")