$re = '/\d{4}/m';
$str = '2\\06\\1998
21.11.1998
18-02-2001
03/05/1999
20 july 1999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);