#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[GET|POST]\s(?<URL>.+(cashAccountOpenings\/v[0-9]|(?=\?)|((?=\/\s)|(?=\s)))).*(HTTP)"
Local $sString = "GET /gw/api/aaa/v1/ HTTP - to return /gw/api/aaa/v1" & @CRLF & _
"GET /gw/api/abc/v3 HTTP - to return /gw/api/abc/v3" & @CRLF & _
"POST /gw/api/cba/ HTTP - to return /gw/api/cba" & @CRLF & _
"POST /gw/transactions/swaggers/v2 HTTP - to return /gw/transactions/swaggers/v2" & @CRLF & _
"POST /gw/api/swaggers/v1/asd?dssa HTTP - to return /gw/api/swaggers/v1/asd" & @CRLF & _
"POST /api/swaggers/ HTTP - to return /api/swaggers" & @CRLF & _
"GET /api/cashAccountOpenings/v3/sadsa-123312-1312 HTTP - to return /api/cashAccountOpenings/v3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")